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Session Objectives

● Introduce spreadsheets
● Introduce decision matrixes
● Use relative and absolute addressing
● Create a generic decision matrix
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A spreadsheet is a problem solving 
tool that...
● Stores and processes data.
● Graphically displays data.
● Performs statistical analyses.
● Fits equations to data.
● Solves equations.
● Optimizes solutions through iterative solving.
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Spreadsheet Fundamentals
● Developed for accountants for financial use
● Each piece of data is located in a "cell"
● A cell is designated by the column (letter) and 

row (number)

Example: The word "Item" is in cell A1, 
which is in column A and row 1.
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What is a Decision Matrix?

● A decision matrix...
● Lists your alternatives (choices or candidates) 

and your criteria (desired outcomes or values).
● Is a method to numerically evaluate which 

alternative best fits your criteria.

● The decision matrix does not make a 
decision for you, it only helps to organize 
your thoughts.

● See example in Eide, pg. 112, Figure 2.19.
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Decision Matrix

Candidates
Alternative 1 Alternative 2 Alternative 3

Criteria Rating Score Rating Score Rating Score
Property 1
Property 2
Property 3

...

Property n
Total 100 Total 1 Total 2 Total 3

Weighting 
Factor (%)

Measure of importance of 
criterion (property)

Score = Weighting Factor * Rating

Rating is how well
alternative meets that
criterion (property)
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Buying a New Car

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance
Style/Appearance
Gas Mileage
Safety
High Reliability
Low Price
Total 100

Weighting 
Factor (%)

● Let's say you are buying a new car and are 
considering three different cars (alternatives).

● You also identified the properties that are 
most important to you in buying a new car 
(criteria).
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Buyer 1- On a budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 5
Style/Appearance 10
Gas Mileage 20
Safety 15
High Reliability 20
Low Price 30
Total 100

Weighting 
Factor (%)

Measure of importance of criterion

● If you are on a budget, then “Low Price” is 
your most important criterion and therefore 
has the highest weighting factor (30%).

● Notice that the weighting factors must add 
up to 100%.
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Rating Alternatives
● Alternatives must be rated on how well they 

meet each criterion.
● Rating Scale
● Excellent 9-10
● Good 7-8
● Fair 5-6
● Poor 3-4
● Unsatisfactory 0-2

● See Eide, pg. 112
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Buyer 1- On a budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 5 2 5 10
Style/Appearance 10 3 6 9
Gas Mileage 20 10 6 4
Safety 15 4 8 4
High Reliability 20 6 8 3
Low Price 30 10 6 1
Total 100

Weighting 
Factor (%)

● The Neon car is very affordable, therefore it 
meets the criteria of “Low Price” very well, 
receiving a rating of 10.
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Buyer 1- On a budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 5 2 10 5 25 10 50
Style/Appearance 10 3 30 6 60 9 90
Gas Mileage 20 10 200 6 120 4 80
Safety 15 4 60 8 120 4 60
High Reliability 20 6 120 8 160 3 60
Low Price 30 10 300 6 180 1 30
Total 100 720 665 370

Weighting 
Factor (%)

● The total score for the Neon is the highest, 
making it the best choice for you.

Score = Weighting Factor * Rating



12

Buyer 2- Unlimited budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 30
Style/Appearance 30
Gas Mileage 5
Safety 20
High Reliability 10
Low Price 5
Total 100

Weighting 
Factor (%)

● If you are now a buyer with unlimited funds 
then your values change and so do the 
weighting factors.

● Now “High Performance” and 
“Style/Appearance” are the most important.
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Buyer 2- Unlimited budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 30 2 5 10
Style/Appearance 30 3 6 9
Gas Mileage 5 10 6 4
Safety 20 4 8 4
High Reliability 10 6 8 3
Low Price 5 10 6 1
Total 100

Weighting 
Factor (%)

● Notice that the rating for each alternative 
doesn't change, because each candidate still 
meets the criteria the same.

● When your values change, only the 
weighting factor should be affected.
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Buyer 2- Unlimited budget

Candidates
Neon VW Jetta Porsche 911

Criteria Rating Score Rating Score Rating Score
High Performance 30 2 60 5 150 10 300
Style/Appearance 30 3 90 6 180 9 270
Gas Mileage 5 10 50 6 30 4 20
Safety 20 4 80 8 160 4 80
High Reliability 10 6 60 8 80 3 30
Low Price 5 10 50 6 30 1 5
Total 100 390 630 705

Weighting 
Factor (%)

● Now the total score for the Porsche is the 
highest, making it the best choice for you.
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Let's Try It...

• Open Excel and open a new spreadsheet
– Go to File � New � Spreadsheet

• Create a blank Decision Matrix
– Enter the text below in cells

These are merged cells

Rating Score Rating Score Rating Score
Property 1
Property 2
Property 3
Property 4
Property 5
Total

Alternative 3
Criteria

Weighting 
Factor (%)

Alernative 1 Alternative 2
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Text Formatting Hints

● To merge cells:
● Highlight the cells to be merged
● Click on square with “A” in it.

● To unmerge cells:
● Select the cell to be unmerged
● Go to Format ⇒ Cells ⇒ Deselect “Merge Cells”

● To word-wrap text in a cell:
● Select the cell/cells to format
● Go to Format ⇒ Cells...
● Click on the Alignment tab and select Wrap Text
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Spreadsheet Calculation Basics

● Calculations or equations are done in their 
own cell.

● Each equation begins with an "=".
● Equations can use relative and absolute 

addressing.
● Equations may contain functions.  For 

example:
● =sum(L#:L#)  Adds a group of numbers
● =average(L#:L#)  Computes the average
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Relative Addressing
● Cells can be added (+), subtracted (-), multiplied (*), 

and divided (/) simply by typing their cell reference.

● For example, if you would like to add the contents of 
cells B2 and C2, you would type in a new cell:

=B2+C2
● If this formula is copied, the cell locations will 

automatically be incremented as shown below.
=B2+C2 ⇒ =B3+C3

A B C D A B C D
1 Internal Equation 1
2 3 2=B2+C2 2 3 2 5
3 6 8=B3+C3 3 6 8 14
4 9 16=B4+C4 4 9 16 25
5 Sum 18 26=sum(D2:D4) 5 Sum 18 26 44
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Copying Hints
● Being able to copy repetitive formulas in a 

spreadsheet will save you a lot of time.
● There are several methods for doing this.
● Method One – Copy/Paste
● Select the cell/cells containing the formula to be 

copied
● Do NOT highlight the formula within the cell

● Go to Edit ⇒ Copy
● Highlight the cells you would like to place the 

copy in
● Go to Edit ⇒ Paste
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Copying Hints – Continued
● Method Two – Quick Fill
● Select the cell containing the formula to copy

● Do NOT highlight the formula within the cell

● Move the cursor to the lower right-hand corner of 
the cell

● The cursor should change to a plus sign

● Click and hold the left mouse button and drag the 
cursor over the cells you'd like to place the copy 
in.

● Method two can only be used with cells that 
are adjacent to the cell you are copying from.
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Checking Formulas
● Whenever you copy and paste formulas you 

will need to check to make sure they copied 
correctly.

● One way to do this:
● Double-click on the cell you would like to check

● This color-codes the formula and cells it references, 
making it easier to check the formula

● It also puts the cell in edit mode, so be careful what you 
type or click on

● To get out of the cell WITHOUT making changes, 
hit ESC

● To get out of the cell keeping the changes you 
made, hit Enter
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Let's Try It...
● Enter in the given numbers for Weighting Factor.

● Enter in the given numbers for Rating.

● Enter the formula for the first Alternative 1 score.

● =Weighting Factor * Rating
● Copy the formula into the four cells below it using 

the Quick Fill method – check the formulas and 
notice how they incremented.

Alternative 1 Alternative 2 Alternative 3
Criteria Rating Score Rating Score Rating Score
Property 1 20 3 60 2 2
Property 2 10 7 70 1 5
Property 3 40 4 160 8 3
Property 4 5 6 6 3 8
Property 5 25 5 125 4 9
Total

Weighting 
Factor (%)
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Let's Try It...
● Copy formulas from the Alternative 1 column into 

the Alternative 2 column.

● Use the Copy/Paste method
● Check the formulas.  Did they copy correctly?

● No!  They shouldn't have...

Alternative 1 Alternative 2 Alternative 3
Criteria Rating Score Rating Score Rating Score
Property 1 20 3 60 2 120 2
Property 2 10 7 70 1 70 5
Property 3 40 4 160 8 1280 3
Property 4 5 6 30 3 90 8
Property 5 25 5 125 4 500 9
Total

Weighting 
Factor (%)

These answers are not correct
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Why didn't the formulas copy 
correctly?

● Spreadsheets help you copy formulas by 
automatically incrementing the cell references

A1 ⇒ B1 ⇒ C1
● Your last copied formulas did not copy correctly 

because of this incrementing

● How do you tell Excel NOT to increment the 
address?

● Absolute Addressing
● Only relevant when COPYING a formula
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Absolute Addressing
● $ designates absolute addressing 
● Type $ in the formula or use shift F4 as a shortcut.
● For example:  =B2+$C$2 

● If the first formula below is copied, B2 will increment 
and $C$2 will NOT increment.

Absolute Addressing Absolute Addressing
A B C D A B C D

1 Internal equation 1
2 3 2=B2+$C$2 2 3 2 5
3 6 8=B3+$C$2 3 6 8 8
4 9 16=B4+$C$2 4 9 16 11
5 Sum: 18 18=SUM($B$2:$B$4) 5 Sum: 18 18 18
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Let's Try It...
● Update the formulas for the first Alternative 1 score 

to use Absolute addressing for the Weighting 
Factor.

= $B3*C3 
Only the column (B) is absolute, not the row (3)

● Copy this formula into the 4 cells below it and then 
to Alternatives 2 & 3.

Alternative 1 Alternative 2 Alternative 3
Criteria Rating Score Rating Score Rating Score
Property 1 20 3 60 2 40 2 40
Property 2 10 7 70 1 10 5 50
Property 3 40 4 160 8 320 3 120
Property 4 5 6 30 3 15 8 40
Property 5 25 5 125 4 100 9 225
Total

Weighting 
Factor (%)
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Let's Try It...
● Sum the weighting factors and each of the 

scores using the sum function
=sum(L#:L#)
● Hint:  in the cell type “=sum(” then 

highlight the cells to be added and hit 
return Alternative 1 Alternative 2 Alternative 3

Criteria Rating Score Rating Score Rating Score
Property 1 20 3 60 2 40 2 40
Property 2 10 7 70 1 10 5 50
Property 3 40 4 160 8 320 3 120
Property 4 5 6 30 3 15 8 40
Property 5 25 5 125 4 100 9 225
Total 100 445 485 475

Weighting 
Factor (%)
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Completing Your Homework

● To finish your decision matrix for your 
homework, you simply need to...
● Fill in the engineering majors you chose for 

alternatives
● Fill in the five criteria you feel are most important
● Update the weighting factors and ratings for each 

to reflect your values and research

● Printing your homework.  Two copies...
● One showing the numbers (default setting)
● One showing the formulas
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Printing out Equations/Formulas
In Excel
● To show formulas:

● Go to Tools ⇒ Formula Auditing ⇒ Formula 
Auditing Mode

● Formulas will show up on sheet
● Check Formulas and Column & Row Headers

● If equations do not fit in the cells:
● Increase column width

● Reverse procedure to turn the formulas off

● To print only a portion of the screen:
● Highlight portion to print 
● Go to File ⇒ Print Area ⇒ Set Print Area
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Hopefully by this point you...

● Are familiar with spreadsheet basics, including 
formatting text, entering formulas, and using 
functions.

● Understand how to use relative and absolute 
addressing.

● Have a generic decision matrix, with the correct 
formulas entered.

Also, don't forget to SAVE your work!


